Recent Comments
From categories:
page 1123...next »
Larry (guest) 29 Nov 2017 23:41
in discussion SManager / SManager Application » My script needs android.permission.DUMP

….And it's not rooted. (I clearly need more sleep, sorry….)

by Larry (guest), 29 Nov 2017 23:41
Larry (guest) 29 Nov 2017 23:40
in discussion SManager / SManager Application » My script needs android.permission.DUMP

Sorry. I forgot to mention that I have a Moto 5+ running Nougat 7.0

by Larry (guest), 29 Nov 2017 23:40

I'm using dumpsys in my boot script, but it errors because it needs android.permission.DUMP. However, I can't grant this permission because os.tools.scriptmanager doesn't request that permission! I get an "Operation not allowed: java.lang.SecurityException" error in adb shell when trying to add the permission. HELP!

My script needs android.permission.DUMP by Larry (guest), 29 Nov 2017 23:37
Time delay
Christine (guest) 29 Oct 2017 07:13
in discussion SManager / SManager Application » Time delay

Hello,

i need a time delay for my script on boot. Can you explain me, how i can configure it. ?

best regards

Christine

Time delay by Christine (guest), 29 Oct 2017 07:13

A little more fiddling, and I think I've confirmed that I have to do both: mark the script SU to run as root, and select "is executable".

Turns out that the solution is to mark SU in the script configuration so that it runs with root privileges. That seems to have solved the problem. I also fiddled with the choice between "is script" and "is executable" but I don't think that one mattered (and I have no idea what it actually does).

I've got a shell script that just runs ffmpeg to save an internet audio stream. If I manually run it from smanager, it works fine. If I schedule it, I get an error from ffmpeg that it can't access the network. I do have WAKE_LOG enabled, but it seems like maybe it is not waking up the network?

I'm using Android Lollipop on rooted Amazon Fire Tablet (XDA Fire Nexus ROM).

Not sure if this is an issue with my script, with SManager, or with my Android ROM.

daxue (guest) 28 Jun 2017 13:14
in discussion SManager / Bugs » Reboot script not working on Samsung Galaxy Ace

must root first, then tick the root option

by daxue (guest), 28 Jun 2017 13:14
PaulSD (guest) 22 May 2017 21:15
in discussion SManager / Scripts » Running a .bat file

Batch files are scripts for Microsoft Windows / DOS based operating systems. Android is a Linux based operating system, so batch files are not supported. You should use a Bourne shell (sh) script instead.

by PaulSD (guest), 22 May 2017 21:15

I would like to ran a script. I wrote the script and it works(tested through adb shell and executing it). Now I would like to add it in SManager so that I can execute it without adb.. In the script-mode, SManager says: "No favourites configured. please set at least one script as favourite." How do I do that? I didn't find an answer in the Manual. In browser-Mode, I can select the script, but there's no option to select it as a favourite.

Maybe I'm dumb: How to create a favourite? by Thomas Heuving (guest), 05 Apr 2017 19:01

Can I run a test.bat file using SManager on my android tablet. I've installed Root Checker, Kingroot. I've also installed SMWidgets, and SManager. I've played around inside but cannot seem to run the file. Below is what i'm trying to run.

@echo off
title Math
color 0e
::this is a test program

:pgOne
set /a sum=10/5
echo %sum%
pause >nul

Running a .bat file by geraldinejnsgeraldinejns, 31 Mar 2017 13:03

good evening,
This is my first approach to this world and I apologize for any errors.

Dovendomi interfacing with a card, through the internet, I am asked the AES-128 encryption, you can with this app?

You can create executable scripts, they can send in Telenet, a series of encrypted commands (I would put the icon on the mobile home)?

example:
(connection)
telnet xxx. xxx. xxx. xxx 85

(Request Welcome Message Sending)
$ H \ r \ n
(Waiting for answer 'OK ​​\ r \ n' to establish communication)

(Close the relay for 1 second)
$ Cx001s \ r \ n
(Expect a new message 'OK \ r \ n' to know that the command has been sent correctly)

[End example]

Also it is possible to intercept the answers 'OK \ r \ n' and print a message on the screen?

buonasera,
questo è il mio primo approccio, a questo mondo e mi scuso per gli eventuali errori.

Dovendomi interfacciare con una scheda, tramite internet, mi viene richiesto la criptazione AES-128, è possibile con questa app?

Si possono creare degli script eseguibili, che possano inviare, in telenet, una serie di comandi criptati (vorrei mettere delle icone sulla home del cellulare)?

esempio:
(collegamento)
telnet xxx.xxx.xxx.xxx 85

(Invio richiesta messaggio di benvenuto)
$H\r\n
(aspetto la risposta "OK\r\n" per stabilire una comunicazione)

(chiudo il relè per 1 secondo)
$Cx001s\r\n
(aspetto un nuovo messaggio "OK\r\n" per sapere che il comando è stato inviato correttamente)

[fine esempio]

Inoltre è possibile intercettare le risposte "OK\r\n" e stampare a video un messaggio?

script crifrati AES-128 by AwialexAwialex, 16 Mar 2017 16:08
Fred (guest) 16 Jan 2017 22:21
in discussion SManager / SManager Application » CM14 / 7.1 / nougat

Yes, please update to 7.1! Really need this app.

by Fred (guest), 16 Jan 2017 22:21
CM14 / 7.1 / nougat
mankokoma (guest) 27 Nov 2016 07:46
in discussion SManager / SManager Application » CM14 / 7.1 / nougat

This used to be my favorite app. Will there ever be an update for CM14 / 7.1 / nougat? It's a pity to see it abandoned…

CM14 / 7.1 / nougat by mankokoma (guest), 27 Nov 2016 07:46

When I long press on a file and select 'delete'. The menu that pops up includes a tick box 'Remove Configuration'. What is the effect of selecting this box? The file seems to get deleted whether it is ticked or not.

What does "Remove Configuration" configuration do by Oliver (guest), 17 Aug 2016 21:02

Hi,

How can you use the command rsync? It seems it's not present in Android (Lollipop), I have an error message when I try to use it and I haven't found it in Busybox.

Thank you.

Hello,

I have a question regarding the way the console is started with SManager.
I found the settings to change the shell which is started.
I found also the setting to change the $HOME shell variable and it will start in this directory.

I have a .profile file in this directory, but it will get not started.
When I start a login shell "sh -l" in the console manually, the .profile is started.

Is there a way to add the "-l" parameter for the console shell?
Or define the initial script for the console shell in the settings?
Btw it would be a good thing to have different init-scripts for console shell and unmanaged-scripts.

Thx for your support,
Lubensius

Console profile by LubernsiusLubernsius, 26 Dec 2015 14:37

I need a way to ask a password and pass it as a parameter. The script run smoothly with hardcoded password.

Thanks

Can a script ask for a password? by Mda (guest), 23 Dec 2015 20:36
Kamil Czerwiński (guest) 18 Oct 2015 22:42
in discussion Hidden / Per page discussions » SManager Manual

Prosze SManagera utworzyć na Facebooka. Dziękuje serdecznie.

by Kamil Czerwiński (guest), 18 Oct 2015 22:42

hi

have rooted an s5830 running android 2.3.3 and have tried a simple reboot script.

The script contains:
#!/system/bin/sh
reboot

am I doing anything wrong?
thanks

Reboot script not working on Samsung Galaxy Ace by Amos (guest), 28 Sep 2015 14:03
page 1123...next »
Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License